大人気SEOプラグインWordPress SEO by Yoastに脆弱性

定番のSEOプラグインである「WordPress SEO by Yoast」に脆弱性が報告されております。

 

(以前の同プラグインに関する脆弱性速報はこちら↓↓

100万ダウンロード以上、大人気SEOプラグイン、WordPress SEO by Yoast に脆弱性

 

今回発見された脆弱性はXSS(クロスサイトスクリプティング)で、バージョン2.1.1以下で発生しているようです。


Info

Affects: Yoast WordPress SEO Plugin <= 2.1.1
Download URL: https://wordpress.org/plugins/wordpress-seo/

Description

The “snippet preview” functionality of the Yoast WordPress SEO plugin prior to version 2.2 was susceptible to cross-site scripting in the admin panel, related to the “metabox” functionality. This vulnerability appears to have been reported 2 years ago by someone named “badconker” (link: https://wordpress.org/support/topic/security-issue-with-post-title-field-xss-vulnerability#post-3575617), but the plugin author said that it had already been patched at the time.

The issue can be triggered by entering arbitrary HTML into the post title field, such as in the example URL provided below.

 


 

すぐに修正版であるバージョン2.2がリリースされております。

(現在の最新版はバージョン2.2.1です)

 

当プラグインは総ダウンロード数1900万件を超える超メジャープラグインですので、ご利用の方も多いかと思います。

 

まだ更新されていない方は早急な最新版へのアップデートをお勧めします。

 

 

 

LINEで送る
Pocket

Related Posts