WordPress用プラグイン「wp Foro Forum」にクロスサイトスクリプティングの脆弱性

WordPressのサイトにBBS(掲示板)あるいはフォーラムと呼ばれるものを組み込みたいと思った時に入れるプラグインが、「wpForo Forum」です。

 

 

 

このwpForo Forumプラグインにクロスサイトスクリプティングの脆弱性が見つかりました。

クロスサイトスクリプティングとは、

クロスサイトスクリプティングとは、ユーザのアクセス時に表示内容が生成される「動的Webページ」の脆弱性、もしくはその脆弱性を利用した攻撃方法のことです。動的Webページの表示内容生成処理の際、Webページに任意のスクリプトが紛れ込み、Webサイトを閲覧したユーザ環境で紛れ込んだスクリプトが実行されてしまいます。

存在するソフトウェアは、ユーザからの入力に対する無害化を適切に行わないまま、他のユーザに提供する Web ページの出力に含めます。

 

トレンドマイクロHPより

簡単に言うと、情報を取得される、および情報を改ざんされる可能性があるということです。

 

すでにベンダーよりアップデートが配布されております。現在使用しているwpForoプラグインが 1.4.12 未満の場合は、必ずアップデートを行ってください。

wpForo Forum

LINEで送る
Pocket

こんな記事も読まれています